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This document describes the step-by-step workflow in Agisoft to generate orthomosaics from 
drone imagery (RGB and multispectral). These workflows have been designed for the purpose 
of kelp, seagrass and rocky shore mapping within the Habitat Mapping Program at the Hakai 
Institute. This document does not include methods for georeferencing orthos but does include 
the use of ground control points (GCPs).  
 
Requirements 

●​ Agisoft Metashape 
●​ GlintMaskGenerator (for kelp/seagrass) 

Related documents 
ACO Ortho Workflow 
Agisoft Manuals 
USGS metashape workflow 
Agisoft Workflow Example - no GCPs 
Agisoft Workflow Example - With GCPs 
Agisoft Workflow - Reflectance Panel 

Workflow Overview 
1.​ Add Photos 

a.​ Adjust Photo Height (If GCPs used) 
2.​ Create and add glint masks (if required) 
3.​ Calibrate Reflectance (Multispectral Only) 
4.​ Align Photos 
5.​ Add Ground Control Points/Markers (If used)  
6.​ Optimize Camera Alignment parameters  
7.​ Build DEM 
8.​ Build Orthomosaic 
9.​ Export Ortho, Report, DEM (If required) 
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https://github.com/HakaiInstitute/glint-mask-tools/releases
https://docs.google.com/document/d/1aMsCKMIHPppSnABsrrMjmE1NK4BiOZYM/edit
https://www.agisoft.com/downloads/user-manuals/
https://pubs.usgs.gov/publication/ofr20211039
https://agisoft.freshdesk.com/support/solutions/articles/31000157908-orthomosaic-dem-generation-without-gcps-
https://agisoft.freshdesk.com/support/solutions/articles/31000153696
https://agisoft.freshdesk.com/support/solutions/articles/31000148780
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Glint Mask Generation 
During a survey, glint may be present in imagery collected over water due to specular reflection 
or due to high solar elevation. It is possible to remove these artifacts from an orthomosaic by 
using masks. The GlintMaskGenerator (Denouden, et al) automates the process of generating 
masks to use in Agisoft Metashape (Note: glint masking is not available in other 
structure-from-motion software).  
 
This document details the methods for masking out glint in the input images. The glint-masked 
pixels can be replaced with overlapping imagery where glint is not present. Metashape uses 
these masks to figure out how to pick the best pixels to use in the output mosaic, essentially 
eliminating any pixels where the sun is reflecting off the water and making it difficult to see kelp. 
This produces a better quality final orthomosaic where little to no glint is present and also 
reduces errors where the structure-from-motion algorithm detects glint as an image feature.  
 
Note: We have tested this method to reduce foam from swell in rocky intertidal areas, and it 
doesn’t work very well. 
 

1.​ Download the GlintMaskGenerator GUI tool for your operating system from 
https://github.com/HakaiInstitute/glint-mask-tools/releases. 

a.​ This tool is occasionally updated, so it’s best to check for new releases on 
occasion. 

2.​ Extract the contents of the downloaded archive, and open the GUI interface by double 
clicking the GlintMaskGenerator.exe file. 

3.​ Generate the masks using the GUI. 

a.​ The tool currently supports a few kinds of images: 

i.​ 8-bit RGB imagery such as those from the DJI phantoms, and Capture 
One cameras. The images may have more than 3 channels for the ‘RGB’ 
mode, as long as the first 3 channels are RGB, in that order. 

ii.​ Micasense RedEdge (5 band imagery). This mode expects the image 
files to have the IMG_1234_1.tif naming scheme that it outputs by default. 

iii.​ DJI Phantom 4 Pro Multispectral (5 band imagery). This mode expects 
the image files to have the DJI_0012.TIF naming scheme that these 
cameras output by default. 

b.​ Select the directory to the input imagery. 
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https://github.com/HakaiInstitute/glint-mask-tools/releases


c.​ Select the directory to where the masks should be output. 

d.​ You may wish to reduce the “Max workers” parameter for very large image files 
like those from the Capture One cameras. The GUI may crash if the operating 
system detects the program using too much memory because of the parallel 
image processing. 

e.​ Click generate and wait for the program to finish. 
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Generating orthomosaics in Agisoft Metashape 
1.​ After opening, Save your project as .psx- you need a Agisoft Metashape project folder 

for the outputs.  
2.​ Load your imagery. 

a.​ Workflow > Add Photos 
i.​ For RedEdge and P4MS camera, once images are loaded select 

Multi-camera system 
ii.​ Select single-camera system if RGB drone 

b.​ Photo Height Adjustment (For when GCPs are required) Often the initial elevation 
of DJI Photos is way off, so GCPs will be difficult to mark. (ie the GCPs can 
appear above the model) 

i.​ On the reference pane, click “Export Reference” to a csv file, save it 
somewhere 

ii.​ Open the csv file, adjust all the elevation values to whatever the survey 
was flown at, e.g., 50m, and save the file 

iii.​ Go back to the reference pane, Import Reference, open the csv and load 
it as reference for the images, adjust columns as needed 

3.​ Import the glint masks (if using) 
a.​ File > Import > Import masks 

i.​ Method = From File 
ii.​ Apply to = all cameras 
iii.​ Other defaults here are fine. 

b.​ You can see the masks overlaid with the images by double clicking any single 
image in the left-hand menu. 

4.​ Calibration panel for Micasense RedEdge and DJI Phantom 4 Pro Multispectral 
ONLY 

a.​ Add Photos for the Calibration panel. These photos are located in another 
folder called “Calibration Panel” in the same parent folder as the micasense 
imagery. 

i.​ Workflow > Add Photos > Find the calibration folder and add the before 
images for 1 panel 

b.​ You will see a prompt that says that they were moved to a separate folder. 
c.​ Tools > Calibrate reflectance 

i.​ Click Locate panels 
ii.​ For the Micasense: 

1.​ Panel calibration values should come up - if they don’t you can 
load in the .csv file located 
H:\Internal\RS\UAV\Files\Micasense_RedEdge_Panel 

2.​ OR Enter the calibration factor provided by MicaSense 
a.​ Blue (_1) = 0.54 
b.​ Gree (_2) = 0.55 
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c.​ Red (_3) = 0.54 
d.​ NIR (_4) = 0.48 
e.​ RE (_5) = 0.52 

3.​ If the day was clear just tick “use reflectance panels” only. If there 
was cloud also tick “use sun sensor” 

a.​ Then import masks 
iii.​ For DJI Phantom 4 Pro Multispectral 

1.​ Enter the following calibration panel values  

 

●​ 0.5452837841 = Blue 
●​ 0.5457807471 = Green 
●​ 0.5351762195 = Red 
●​ 0.5230233864 = Red Edge 
●​ 0.4797582105 = NIR 
2.​ Select use reflectance panel ONLY 

iv.​ Double check mask for the calibration panel is only set to the panel 

1.​ In some cases the auto detection function for Agisoft includes 
areas outside of the panel. Click the image in the workspace panel 

2.​  
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3.​  

4.​ Under Photo select Intelligent Scissors and draw an area around 
what you want removed from the mask. Then right click and select 
“Add Selection“. Then rerun calibration. 

 

5.​ Align the photos. 

a.​ Workflow > Align photos  

i.​ Use the default presets and High accuracy. 

ii.​ Under Advanced check “Guided image matching”. 

iii.​ Click OK and let the alignment run. 

iv.​ NOTE: Sometimes the images don’t get aligned. These 
are usually largely featureless ground areas like water 
or snow/ice. 

1.​ You can force images to align by selecting the 
unaligned photos and navigating to them in the 
workspace -> select align by reference 

6.​ Adding GCPs / Markers (if used) 

a.​ File-> Import -> Import Reference to add from csv; select required columns 
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b.​ Check the reference settings for the project now - use the dialog and enable 
separate camera and marker reference 

 

c.​ For each marker in the reference pane, right click and “Filter Photos by Marker” 
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d.​ Then go through 10 or so photos in the photos pane and drag the marker to the 
correct location 

e.​ Uncheck any GCPs you want to use as check points  

f.​ Update transformation  
 

7.​ Optimize Cameras (especially important for Multispectral or GCPs) 

a.​ Use the Optimize Cameras option from the Tools menu to refine the camera 
alignment. This step compensates for calibration inaccuracies and improves the 
accuracy of the alignment 
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8.​ Important: If your model is cut off OR if you 

want to crop to focus on an AOI, Rotate and 
resize the region (very light pink box around the 
aligned images) to ensure all image areas are covered.  

9.​ Generate the DEM (Point cloud not required, just Depth Maps) 

a.​ Workflow > Build DEM 

b.​ Set projection to your desired projection (e.g. Canadian NAD83 UTM Z9 (EPSG: 
3156)) 

c.​ Can save this to a known file location for future reference/quick access. 

d.​ Source = Depth Maps 

e.​ Interpolation = Extrapolated vs Default 

i.​ Use default normally. If you notice a part of the DEM is being cut off, 
switch to extrapolated. 
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10.​Tools > Calibrate Colors (this is advised for variable lighting conditions but may be slow, 
doesn’t seem to do much for rgb orthos) 

a.​ Source data: DEM 

b.​ Check calibrate white balance 

11.​Generate the Orthomosaic 

a.​ Workflow > Build Orthomosaic 

b.​ Enable hole filling should be checked. Otherwise leave everything else as 
default. 

12.​Ortho Editing 

In some cases it may be useful to edit an ortho - eg if there are blurry areas or areas with 
waves.  

Agisoft instructions 

●​ Create polygons 
●​ Assign Images (right click) 

11 

https://agisoft.freshdesk.com/support/solutions/articles/31000148853-orthomosaic-seamline-editing-patching-


●​ Update Orthomosaic (Right click on Orthomosaic in Workspace Menu) 

Derek’s tip is to work with small areas at a time 

 

13.​Create clipping boundary 
a.​ Create a polygon of the area you want to export as an ortho 
b.​ Right click on on the polygon, Set Boundary Type, “Outer Boundary” - note: 

multiple overlapping polygons can be used, but all must “set boundary type” as 
“Outer Boundary” for them to work together. 

c.​ When you export ortho, this will be used as a clipping mask if “Clip to boundary 
shapes” is selected 

 

14.​Export the Orthomosaic. 

a.​ File > Export > Export orthomosaic 

i.​ Select “Generate TIFF overviews” and “Write BigTIFF file” (otherwise Tiffs 
will be limited to 4GB in size) 
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ii.​ Set background to black and “write alpha channel” 

iii.​ Hakai: Export location should be the Working folder of each mission on 
the NAS.  

 

15.​Publish DEM - File - Export DEM 

16.​Generate Report (Save with products) File - Export - Generate Report 

 

Other tips and resources: 

You can execute all of the steps unsupervised by adding them in order using Workflow > Batch 
process. I didn’t play with this too much, but it’s likely to be more efficient. 

https://agisoft.freshdesk.com/support/solutions/articles/31000148381-micasense-altum-processi
ng-workflow-including-reflectance-calibration-in-agisoft-metashape-professi 

Video on processing Micasense Imagery 

https://support.micasense.com/hc/en-us/articles/360002693373-Process-MicaSense-sensor-dat
a-in-Agisoft-Metashape 
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https://agisoft.freshdesk.com/support/solutions/articles/31000148381-micasense-altum-processing-workflow-including-reflectance-calibration-in-agisoft-metashape-professi
https://agisoft.freshdesk.com/support/solutions/articles/31000148381-micasense-altum-processing-workflow-including-reflectance-calibration-in-agisoft-metashape-professi
https://support.micasense.com/hc/en-us/articles/360002693373-Process-MicaSense-sensor-data-in-Agisoft-Metashape
https://support.micasense.com/hc/en-us/articles/360002693373-Process-MicaSense-sensor-data-in-Agisoft-Metashape


In case it is necessary to export the reflectance normalized to 0 - 1 range, then it is required to create 
Output bands in the Raster Calculator dialog and for each one of them input the formula that divides the 
source value by the normalization factor: B1/32768; B2/32768; B3/32768; B4/32768; B5/32768 

Tips and tricks:  
-​ Faster to run an instance of Agisoft on a local drive? 
-​ -network processing? 

 

NOTE FOR DATA OUTPUTS 

Agisoft Outputs need to be:​  
○​ 8 bit unsigned (for RGB) 
○​ 16 bit unsigned (for multispectral) 

●​ NoData needs to be set to zero 
●​ You can ensure this when the imagery is being georeferenced in GIS - be sure to  

save as new  rather than update georeferencing/save/rectify. 

 

 

Batch Processing (ie run all steps unattended) 
For automated processing (when no GCPs or glint masking are required), we can use a batch 
process. ​
For example, for processing RGB imagery to create orthos, we have created some pre-defined 
workflows at H:\Internal\RS\UAV\Files\1_Folders_template_drone_fieldwork\Working. 
Go to the workflow menu, then select batch. Then click on the folder icon bottom right to find the 
correct xml file in the template folder. If all steps are selected, they will all run unattended. 
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